Domänensuche funktioniert nicht

In einigen Fällen wurde trotz offensichtlich korrekt durchgeführter Konfiguration berichtet, dass die Domänensuche nicht funktioniert – genauer gesagt: Der DomainIndexer – Task führte keine Indizierung der vorgesehenen Datenbanken durch. In den Ansichten „Domain Indexer Status“ der Datenbank CATALOG.NSF gab es auch keine Dokumente, die normalerweise die Ausführung der Indizierung protokollieren.

Hierzu meine Beobachtungen
Mit einer schon vor der Einrichtung der Domöne existierenden Datenbank CATALOG.NSF hat die Aktivierung der Domänensuche bei mir noch NIE funktioniert.

Erst wenn man die bestehende CATALOG.NSF löscht und (vorher natürlich die Domänensuche aktivieren, ggf. Server Neustart) dann via LOAD CATALOG neu erstellen lässt, funktionierte das problemlos.

Interessanter Nebeneffekt:
Der normale Datenbankkatalog trägt z.B. den DB-Titel „Catalog (6)“. Wenn die Domänensuche aktiviert wurde und man erstellt mittels LOAD CATALOG die Datenbank neu, trägt sie einen anderen Titel, z.B.: „Domain Catalog“.

Ich vermute, das die DB beim Erstellen – wenn die Domänensuche aktiviert wurde – intern ein spezielles Flag erhält – und dann funktioniert auch der Domain-Indexer und dann die Suche…

Zusätzlich werden Sie noch feststellen, das die ACL der neu erstellten CATALOG.NSF einen Gruppen-Eintrag „Domain Catalog Servers“ automatisch erhält (je nach eingesetzter Version wird diese Gruppe auch automatisch in der NAMES.NSF auf dem Domino-Server erstellt).

Bei manchen 5er Versionen war die Gruppe aber auf die ACL-Zugriffsebene Leser eingestellt – Replikation mit anderen Servern hat dann nicht funktioniert. Ein manuelles löschen der Gruppe brachte da nix – die Gruppe wurde automatisch wieder mit Leser-Rechten hinzugefügt. Ich habe dann immer alle Server explizit in die ACL eingetragen – danach funktionierte auch die Replikation…

Notes/Domino Version: 5.x, 6.x